Updated: Mobile SDK 1.7.4 No Longer Available, 1.7.5 Coming Soon

Copy space. New arrows painted on asphalt. Direction future.

Update: 1.7.4 Release pulled from build servers – update no longer available

The 1.7.4 release has been pulled from our download servers at this time – we are currently tracking two critical issues that are preventing us from making 1.7.4 generally available:

If you have not yet upgraded to 1.7.4, no further action is necessary. If you have upgraded to 1.7.4 while the update was available yesterday, we recommend that you revert your project back to the 1.7.3 release. The properties API issue has been fixed in the 1.7.x release branch, and is available from our continuous integration server if required.

We plan to make a 1.7.5 release in the coming days once the necessary testing is complete, which will contain fixes for the critical issues mentioned above. Thank you for your patience, and we apologize for any inconvenience.

Original Post

Today, we are making the 1.7.4 release of the Titanium Mobile SDK generally available to the community. The 1.7.4 release contains several important bug fixes, summarized below. The official release notes for 1.7.4 are located here.

Thank you as always to all our users, and let us know what you think!  Titanium Studio should prompt you to update automatically, but you can check for the 1.7.4 update by selecting “Check For Titanium SDK Updates…” in the “Help” menu of Titanium Studio.

Bugs Squashed

  • [TIMOB-1419] – Update Titanium.Facebook to use Facebook's New OAuth 2.0 Authentication
  • [TIMOB-2849] – Android: Set-Cookie Response Headers Only Returns Max of One Cookie
  • [TIMOB-4482] – Android: Tabgroup.animate not working on Android 2.2 with Ti sdk 1.7.0
  • [TIMOB-4696] – iOS: Cannot retrieve property value set in tiapp.xml using Ti.App.Properties API
  • [TIMOB-4741] – iOS: Percentage-based views need to be re-drawn on device rotation
  • [TIMOB-4747] – Android: passwordMask and keyboardType
  • [TIMOB-4888] – iOS: app does not rotate to landscape if it is launched while the device is in landscape
  • [TIMOB-4947] – Android: Window close event not fired for heavyweight window
  • [TIMOB-5123] – CommonJS Modules not included/functional in distribution build
  • [TIMOB-5331] – iOS: Launching in landscape and then rotating to portrait causes popover button to disappear
  • [TIMOB-5332] – iOS: Rotating a popover causes the content to be removed from popover but the popover stays
  • [TIMOB-5405] – iOS5: Intermittent Running Countdown picker and letting it go to the background crashed
  • [TIMOB-5434] – Android: require() in a non-root context breaks any include() statements below it.
  • [TIMOB-5748] – Android: Debugger in Android does not stop at the breakpoints that are required by (require(file.js) )
  • [TIMOB-5752] – Android: Ti.Platform.id not unique
  • [TIMOB-5755] – iOS: xcode 4.1+ cannot compile to armv6, application crashes on launch
  • [TIMOB-5804] – iOS: Cannot launch app on device.
  • [TIMOB-5805] – Reintegrate uniqueIdentifier value into id property and add PB caching support.
  • [TIMOB-5819] – Android: Percentage-based views need to be re-drawn on device rotation
  • [TIMOB-5827] – iOS: Opening window in full screen does not cover the nav bar
  • [TIMOB-5828] – Kitchensink: Navbar does not change size when rotating to landscape on main windows.
  • [TIMOB-5834] – Kitchen Sink crash on launch in iPad 1 (os version 3.2.2) in landscape orientation

16 COMMENTS

  1. Is it normal that after update , there is no “SDK Version: 1.7.4” in tiapp.xml ?
    Doesn’t seem to get folder in Library/Application Support/Titanium/mobilesdk/osx..

    is it delayed because of App Properties bug ?

    Thanks for answer

  2. We’ve temporarily removed the 1.7.4 release, pending changes for the properties API issue. We will be releasing further information and a go-forward plan today.

    Thanks for your patience.

  3. @Kevin which version is the “official stable” release in your CI server?
    I’m afraid that they are just nightly builds and not the stable releases.
    Thanks,

  4. Is it normal that under iOs5 and Ti SDK 1.7.3, it is also impossible to install on iPhone devices ?

  5. @hiron the 1_7_x branch only receives critical fixes and can be considered stable. It is very close to 1.7.3.

    @Jean-Sebastien you should be able to install to an iOS 5 device with 1.7.3 – if you’re not able to do so, register a Q&A item and we can take a look.

  6. @Kevin thanks for your answer…I closed the topic in Q&A … it cames from an unused js files…an incorrect variable initialization but this was not causing error before iOS 5 (for other people).

Comments are closed.